[ABD] BRIDGE phpBB & WordPress

Un lugar para que los autores de modificaciones envíen y reciban información sobre MODs aún en desarrollo. Los MODS dentro de este foro NO deben ser utilizado en un entorno real!

Moderador: Personalizaciones de Extensiones

Avatar de Usuario
Juanla
Menos de 100 mensajes
Menos de 100 mensajes
Mensajes: 48
Registrado: Lun Dic 13, 2010 7:49 pm

Re: [DEV] BRIDGE phpBB & WordPress

Mensaje sin leer por Juanla » Dom Jul 24, 2011 1:05 pm

Patrocinador

abro un tema en soporte? o aquí mismo? Lo del foro se entiende, sólo que al leerlo rápido creo que cambié de lugar los 2

Avatar de Usuario
Leviatan21
Lider phpBB Argentina
Lider phpBB Argentina
Mensajes: 1993
Registrado: Mié Nov 25, 2009 4:43 pm
Ubicación: Buenos Aires, Argentina
Contactar:

Re: [DEV] BRIDGE phpBB & WordPress

Mensaje sin leer por Leviatan21 » Dom Jul 24, 2011 2:51 pm

Sigue aqui, ya que este tema es justamente para resolver posibles problemas antes de su lanzamiento
Lea las reglas | Nosotros | Acerca de phpBB | Descargas | Soporte | Blog
Ex Miembro del Equipo QA en phpbb.com
No se brindará soporte por Mensaje Privado, por favor pregunte en un tema público, tenga en cuenta que su problema puede ser también un problema para otros ;)

Avatar de Usuario
Juanla
Menos de 100 mensajes
Menos de 100 mensajes
Mensajes: 48
Registrado: Lun Dic 13, 2010 7:49 pm

Re: [DEV] BRIDGE phpBB & WordPress

Mensaje sin leer por Juanla » Dom Jul 24, 2011 5:04 pm

Leviatan21 escribió:Sigue aqui, ya que este tema es justamente para resolver posibles problemas antes de su lanzamiento
Deacuerdo :D

Bueno pues el error me lo da al enviar una entrada nueva desde wordpress.

Código: Seleccionar todo

Fatal error: Call to a member function set_url() on a non-object in /homepages/30/d355761830/htdocs/foro/includes/functions_posting.php on line 2623
La entrada se envía correctamente, o eso parece al menos.

URL: http://admin1234.com/foro
Versión del foro: 3.0.9
Estilo: prosilver (3.0.9)
Mods: phpBBSEO premod (con los que incluye con él) Activity Stats Mod, Advertisement Management, Auto backup, Topic statics hook, por supuesto este mod, y algunos cambios en las plantillas.

Avatar de Usuario
Leviatan21
Lider phpBB Argentina
Lider phpBB Argentina
Mensajes: 1993
Registrado: Mié Nov 25, 2009 4:43 pm
Ubicación: Buenos Aires, Argentina
Contactar:

Re: [DEV] BRIDGE phpBB & WordPress

Mensaje sin leer por Leviatan21 » Mar Jul 26, 2011 2:44 pm

Lamento la tardanza, pero no me fue fácil resolverlo, el MOD SEO y WP entran en conflicto y lo único que me funcionó es este parche que evita al SEO al momento de crear el mensaje en phpBB, ya que dentro del WP no lo necesitamos.

Abrir :

Código: Seleccionar todo

raíz/includes/function_posting.php
Buscar :

Código: Seleccionar todo

    // www.phpBB-SEO.com SEO TOOLKIT BEGIN
    $phpbb_seo->set_url($data['forum_name'], $data['forum_id'], 'forum');
    if ( $params ) {
        $phpbb_seo->prepare_iurl($data, 'topic', $topic_type == POST_GLOBAL ? $phpbb_seo->seo_static['global_announce'] : $phpbb_seo->seo_url['forum'][$data['forum_id']]);
    }
    // www.phpBB-SEO.com SEO TOOLKIT END 
Reemplazar, por :

Código: Seleccionar todo

// MOD : WordPress - phpBB Integration Mod - START
if (!defined('IN_WP_PHPBB_BRIDGE'))
{
// MOD : WordPress - phpBB Integration Mod - END
    // www.phpBB-SEO.com SEO TOOLKIT BEGIN
    $phpbb_seo->set_url($data['forum_name'], $data['forum_id'], 'forum');
    if ( $params ) {
        $phpbb_seo->prepare_iurl($data, 'topic', $topic_type == POST_GLOBAL ? $phpbb_seo->seo_static['global_announce'] : $phpbb_seo->seo_url['forum'][$data['forum_id']]);
    }
    // www.phpBB-SEO.com SEO TOOLKIT END
// MOD : WordPress - phpBB Integration Mod - START
}
// MOD : WordPress - phpBB Integration Mod - END
 
Lea las reglas | Nosotros | Acerca de phpBB | Descargas | Soporte | Blog
Ex Miembro del Equipo QA en phpbb.com
No se brindará soporte por Mensaje Privado, por favor pregunte en un tema público, tenga en cuenta que su problema puede ser también un problema para otros ;)

Avatar de Usuario
Juanla
Menos de 100 mensajes
Menos de 100 mensajes
Mensajes: 48
Registrado: Lun Dic 13, 2010 7:49 pm

Re: [DEV] BRIDGE phpBB & WordPress

Mensaje sin leer por Juanla » Mar Jul 26, 2011 5:11 pm

No tienes que preocuparte por la "tardanza", y muchas gracias por el parche :)

Avatar de Usuario
Saske
Ex Miembro del Equipo
Mensajes: 258
Registrado: Sab Feb 05, 2011 9:30 am
Ubicación: España
Contactar:

Re: [DEV] BRIDGE phpBB & WordPress

Mensaje sin leer por Saske » Jue Ago 04, 2011 5:31 am

¿Cual es la URL de su foro?: http://www.espartan3ds.com
¿Con quien hospeda si sitio?: Hosting Infinito
¿Como ha instalado su foro?:
¿Que versión de phpBB está usando?: 3.0.7 pl1
¿Es una instalación nueva o una conversión?: Instalación nueva
Usuario de prueba: Clave:
¿Que estilo(s) tiene actualmente instalados?: Nintendo 3DS
¿Que languaje(s) tiene actualmente instalado?: Es
¿Que tipo y versión de base de datos está utilizando?:
¿Tiene MODs instalados?: Si
¿Cuál es su nivel de experiencia?:
¿Cuando ha comenzado su problema?:
Por favor describa su problema: Bueno, he implementtado el MOD y wordpres en el foro
Se puede acceder desde aquí http://www.espartan3ds.com/blog/
Sin embargo, lo puse que se "uniera" con la url de arriba, si no con el foro "actualizado" http://www.espartan3ds.com/309
Cuando "Actualice" el for rel, cambiare eso en la configuración del plugin de WP (no creo que con esto haya problema)
Sin embargo, el overall_footer.html (basicamente, donde esta el copyright), se sale un poco por abajo, debido a que hay un espacio entre el copyright del plugin y el de la traduccion y demas ...
Como puedo solucionar eso ?
Otro error o bug (aunque pouede que el fallo sea mio), es que cada vez que intento loguarme en el blog de wordpress, me dice que me identifique con exito, pero luego "al volver a la pagina anterior" ya no estoy logueado ...
Es un problema de cookies, tengo algo mal configurado ?¿
Es problema del foro phpBB ?¿ (aunque en este no me desloguea)
:roll:

Avatar de Usuario
Leviatan21
Lider phpBB Argentina
Lider phpBB Argentina
Mensajes: 1993
Registrado: Mié Nov 25, 2009 4:43 pm
Ubicación: Buenos Aires, Argentina
Contactar:

Re: [DEV] BRIDGE phpBB & WordPress

Mensaje sin leer por Leviatan21 » Jue Ago 04, 2011 12:53 pm

Saske escribió:Sin embargo, el overall_footer.html (basicamente, donde esta el copyright), se sale un poco por abajo, debido a que hay un espacio entre el copyright del plugin y el de la traduccion y demas ...
Como puedo solucionar eso ?
Hay una combinación de hechos, el footer tiene realmente poco espacio y es probable que necesites quitar un enter, prueba haciendo este cambio :
Abrir :

Código: Seleccionar todo

raíz_del_wordpress/wp-content/themes/prosilver/includes/wp_phpbb_bridge_core.php
Buscar :

Código: Seleccionar todo

		$blog_footer .= sprintf(self::$user->lang['WP_RSS_NOTES'], '<a href="' . get_bloginfo('rss2_url') . '">' . self::$user->lang['WP_RSS_ENRIES_LINK'] . '</a>', '<a href="' . get_bloginfo('comments_rss2_url') . '">' . self::$user->lang['WP_RSS_COMMENTS_LINK'] . '</a><br />');
Reemplazar por :

Código: Seleccionar todo

		$blog_footer .= sprintf(self::$user->lang['WP_RSS_NOTES'], '<a href="' . get_bloginfo('rss2_url') . '">' . self::$user->lang['WP_RSS_ENRIES_LINK'] . '</a>', '<a href="' . get_bloginfo('comments_rss2_url') . '">' . self::$user->lang['WP_RSS_COMMENTS_LINK'] . '</a>');
Saske escribió:Otro error o bug (aunque pouede que el fallo sea mio), es que cada vez que intento loguarme en el blog de wordpress, me dice que me identifique con exito, pero luego "al volver a la pagina anterior" ya no estoy logueado ...
Es un problema de cookies, tengo algo mal configurado ?¿
Si es un problema de cookies porque tienes el foro configurado para que la cookie funcione solo en la carpeta /309/ y no para que sea desde el raíz del dominio
Lea las reglas | Nosotros | Acerca de phpBB | Descargas | Soporte | Blog
Ex Miembro del Equipo QA en phpbb.com
No se brindará soporte por Mensaje Privado, por favor pregunte en un tema público, tenga en cuenta que su problema puede ser también un problema para otros ;)

Avatar de Usuario
Saske
Ex Miembro del Equipo
Mensajes: 258
Registrado: Sab Feb 05, 2011 9:30 am
Ubicación: España
Contactar:

Re: [DEV] BRIDGE phpBB & WordPress

Mensaje sin leer por Saske » Jue Ago 04, 2011 1:19 pm

Perfecto, solucionado el problema en el footer ;)
Muchas Gracias
Leviatan21 escribió: Si es un problema de cookies porque tienes el foro configurado para que la cookie funcione solo en la carpeta /309/ y no para que sea desde el raíz del dominio
El "problema" es que en la raiz del dominio hay otro foro phpBB, por eso creo yo que se podrían mezclar las cookies :?: :roll:
De todas, formas, en la configuracion de cookies (en el ACP) cambie /309/ por / me he identificado en el bloc, y al "redirigirme" me lanza
Fatal error: Call to undefined method bbcode::spoil_pass() in /home/espartan/public_html/309/includes/bbcode.php(112) : regexp code on line 1
Cual es el errror ?¿
Además, esta cogiendo el includes/bbbcode.php del foro phpBB de la raiz del dominio, y no del "309" es por eso el error ?¿

Avatar de Usuario
Leviatan21
Lider phpBB Argentina
Lider phpBB Argentina
Mensajes: 1993
Registrado: Mié Nov 25, 2009 4:43 pm
Ubicación: Buenos Aires, Argentina
Contactar:

Re: [DEV] BRIDGE phpBB & WordPress

Mensaje sin leer por Leviatan21 » Jue Ago 04, 2011 1:43 pm

Saske escribió:El "problema" es que en la raiz del dominio hay otro foro phpBB, por eso creo yo que se podrían mezclar las cookies
Para eso tienes el nombre de la cookie, debes cambiarlo para que no sea igual al otro foro ;)
Cuando lo hagas, debes purgar las sesiones desde el ACP -> GENERAL y desde el foro, pulsar el enlace Borrar todas las cookies del Sitio
Luego de identificarte debería funcionar sin problemas.
Saske escribió:me he identificado en el bloc, y al "redirigirme" me lanza
Fatal error: Call to undefined method bbcode::spoil_pass() in /home/espartan/public_html/309/includes/bbcode.php(112) : regexp code on line 1
Cual es el errror ?¿
Además, esta cogiendo el includes/bbbcode.php del foro phpBB de la raiz del dominio, y no del "309" es por eso el error ?¿
¿Tiene MODs instalados?: Si
Supongo que dentro de los MODs instalados está el ABBC3, si está debidamente instalado no deberías tener problemas.
El archivo raíz/includes/bbbcode.php debe estar asociado al raíz/includes/abbbcode.php para que funcionen ciertos bbcodes que están en la base de datos, tanto de bbcodes como de mensajes
Lea las reglas | Nosotros | Acerca de phpBB | Descargas | Soporte | Blog
Ex Miembro del Equipo QA en phpbb.com
No se brindará soporte por Mensaje Privado, por favor pregunte en un tema público, tenga en cuenta que su problema puede ser también un problema para otros ;)

Avatar de Usuario
Saske
Ex Miembro del Equipo
Mensajes: 258
Registrado: Sab Feb 05, 2011 9:30 am
Ubicación: España
Contactar:

Re: [DEV] BRIDGE phpBB & WordPress

Mensaje sin leer por Saske » Jue Ago 04, 2011 2:06 pm

Leviatan21 escribió: Para eso tienes el nombre de la cookie, debes cambiarlo para que no sea igual al otro foro ;)
Cuando lo hagas, debes purgar las sesiones desde el ACP -> GENERAL y desde el foro, pulsar el enlace Borrar todas las cookies del Sitio
Luego de identificarte debería funcionar sin problemas.
Y que nombre le pongo ?¿
No importa el que sea mientars empiece por phpbb_ ?¿
Leviatan21 escribió: Supongo que dentro de los MODs instalados está el ABBC3, si está debidamente instalado no deberías tener problemas.
El archivo raíz/includes/bbbcode.php debe estar asociado al raíz/includes/abbbcode.php para que funcionen ciertos bbcodes que están en la base de datos, tanto de bbcodes como de mensajes
El Advanced BBCode Box, esta instalado en el foro de la raiz, y que yo sepa esta bien instalado (no lo instale yo, creo que lo instalo DaVidU, bastante antes de que yo me registrara en phpBB-es, y empezara con el phpBB etc ...)
De todas formas, si esta cogiendo el includes/bbcode.php del foro que esta en la raiz del servidor, puede que sea el error por que aun es 3.0.7 ... :roll:

Cerrado